Enum Error

Does anyone know what this means?
I know that I cannot use BP enum passed into SK as param.
Therefore I created the enum in C++ and trying to use that but I get this error.
I spend a day trying to move BP Enums to C++ and I’m stuck hmm…

BP and SK are so tightly coupled and I really want a divorce in the new scripting language. Please help!

image

UENUM(BlueprintType)
enum class EPartCategory : uint8
{
	Use,
	Equip, 
	Drop,
	Delete,
};

Basically it means it couldn’t find the type. Are you still getting this? If you transitioned the enum from BP to C++, sometimes you have to re-kick UHT to do its thing. You may also need to delete the auto-generated bp type for the enum from your scripts folder.

Yup, I’m still getting it. And I think I tried everything I could and it’s still there.
I just “ignore” it and it works as if there were no errors.
Annoying but not a roadblock.

ps. The more I use SK, the more problems I run into. I’m spending more and more time trying to find works around, first writing BP but ending up writing c++ codes. It’s not as simple as it sounds. By doing so, I have to fix reference errors all over the places.

BP is so horrible and I really want to stay away from it at all cost. It’s a big mistake Epic decided to get rid of scripting language on UE4 and gave us BP only. Tim wrote why he wants to get rid of scripting language but it’s so wrong. The main reason was writing an interface layer is very difficult but it’s not true. BP requires an interface layer anyway, no? It doesn’t make sense. So much time wasted improving BP but it cannot even do searches properly. And in the meantime, we lost about 10 years and Marketplace is filled with “100% Blueprint” junks.