Running IDE on Mac


I feel like I’m missing something obvious, but for the life of me I can’t get the IDE to show on Mac.

I’ve installed the plugin using the marketplace, and everything seems fine. However, the SkookumIDE button has a red cross mark, and pressing it does nothing. According to the docs, if something like this happens, I’m encouraged to run it manually, but when I try to find a binary for it, I can only see one for Win64 (I’m guessing at this point that docs are outdated, and there is no standalone version for Mac because the new IDE works with Slate).

Logs say nothing, so I’m really at a loss. Is the IDE supposed to work with UE4 4.19.2? How can I troubleshoot this?

Thanks in advance.

Hi Arcnor, thanks for giving SkookumScript a spin. Unfortunately, the IDE currently only works on Windows. You can run it on a Windows machine and connect remotely to a Mac runtime though. Not sure if that would be helpful to you.

So those posts about the new Slate version are not for Mac?

Is this in the works, or do you have any kind of timeframe to when it will be available?

No real reason to test the engine if the IDE is not there :slightly_smiling_face:

The Slate/UI aspect of the SkookumIDE is platform independent though there are a bunch of file and communication aspects that are currently only Windows. :sweat_smile:

The plan is to eventually ensure everything is platform independent though it is not scheduled any time soon.

For the foreseeable future the only Mac runtime option is to run the SkookumIDE on a nearby Windows PC or try to emulate Windows on the Mac (though not sure of the success of the latter).

That’s really unfortunate.

I’ve tried virtualization, both Wine (different versions, PortingKit, etc) as well as VirtualBox with a full Win7 installation, but none of them have worked.

Are the missing parts (I/O) something I can fix myself (i.e. are those part of the open source repo)?

Finally, is there a 32 bit version of the IDE? The only machines with Windows I can find are 32 bit.