[Solved] Need Help Installing Skookum

Hey there!

I’m trying to install the Skookum plugin for UE 4.23.1 through this GitHub page. However, when I run the Setup.bat command, I get to 99% of the process (took 4+ hours) and then the script fails out, because the link to the commit hash name is too long; git complains the directory needs to be 260 characters or less (classic Windows DOS problem if I’m not mistaken). This is in the “updating dependencies” stage of the setup.

I’ve also tried installing the plugin as a binary through here, and although the Plugin installs, and I can launch the Editor and see a Skookum button, and even have the Skookum IDE, the program then complains that one of its modules doesn’t exist (Skookum ScriptGenerator). Trying to build the Project using the Windows context menu to right-click on my UE4 project file and using “build project files” fails, and requests I rebuild from source. That fails, because it can’t find the Skookum ScriptGenerator module, again. If I rebuild only the Unreal Engine itself (so not my game project), the build succeeds instantly, and Skookum doesn’t fail out.

It appears I can’t get Unreal to properly locate the installation directory of Skookum, which is just Engine/Plugins, where it belongs. What is true is that my UE installation is on a different drive (i.e. the Z: drive) than the Project (the C: drive).

I could use some instructions on how to properly install the newest version of Skookum for 4.23.1. Apparently the instructions for dummies on the GitHub isn’t dummy enough for me. xD

Thank you a lot for your time,


Specifically, the DOS error is:
Failed to download 'http://cdn.unrealengine.com/dependencies/UnrealEngine-4358751-16521f530c414728b289dbb71f593410/80c1ba699c3de9b0950a5521e587025e7f85f8bb': the specified path, fie name, or both are too long. The fully qualified file name must be less than 260 characters, and the directory name must be less than 248 characters. (PathTooLongException)

I can download this file myself; is there any clear indication where it belongs so I can manually place it there?

Found this on the Unreal Forums. It might help me resolve my issue. I’ll post again if I manage to successfully build Skookum after all.

Correct. This helped me continue my setup. I’ll post an actual new reply to the topic if I manage to set up my environment in a working fashion. Otherwise, consider this still open and me actively looking for help.

Have to change the GenerateProjectFiles-SkookumIDE.bat file manually to make sure it points to the location my Python installation is actually installed; and it’s running into some space parsing issues (“Z:\Program” is not a recognised command – obviously failing to correctly parse Z:\Program Files\ as a directory).

Simply moving the installation folder to a location that did not contain spaces in its path name was an easy solution there. Didn’t want to dive deep into recursive calls to other batch files to fix that issue.

Hey there. Where are you currently at here in troubleshooting? In your post it looks like you’re trying to build the SkookumIDE, build the plugin and also use the binary plugin.

As a quick bit of info:
https://github.com/error454/UnrealEngine is used to build the SkookumIDE
https://github.com/SkookumScript/SkookumScript-Plugin is used to build the :sk: plugin but does not include the IDE
https://github.com/SkookumScript/SkookumScript-Plugin/releases/download/v4.23.1/SkookumScript-4.23.1-0f37cd6.7z is the current release of the :sk: plugin that includes the SkookumIDE. I’d recommend using this by unzipping into Engine/Plugins/Runtime/SkookumScript

Can you elaborate on this? A missing module error will prevent the launch of the editor. Are you sure you didn’t perhaps have 2 different versions of :sk: installed, one in the engine folder and one in your project folder?

All you should need is the binary release unzipped in your engine folder and you should be done. If when you launch your project it complains that there are missing SkookumScript modules then please be sure that you are actually running the 4.23.1 release from the :ue4: launcher and not the 4.23.0 release.

1 Like

Ah! I tried installing it in Engine/Plugins rather than Engine/Plugins/Runtime. Thanks for the heads-up.

Eyyy that totally worked. Thanks so much. It was super easy, too. Must’ve completely misunderstood the installation instructions to botch it up so hard.

Oh man I’m excited for tomorrow. Time to get cracking on Skookum!

1 Like

Ran into some more errors, but after I opened my project in Visual Studio and Built it, then restarted the Editor, then got a different kind of error and just followed its instructions to resolve the errors, I can now start my UE4 Editor, launch a Skookum IDE and get… zero errors! Eyy!

Specifically, I ran into:

  • “overlay in skookum-project.ini doesn’t match skookum-project-default.ini”; basically, I had to “insert” one of the missing overlays into my skookum-project.ini and shift all the remaining ones down
  • “Some binaries couldn’t compile because of errors; either press Try Again or Continue based on what error you see in the error log” – I pressed Try Again --> led into an “It looks like things need to be regenerated; please restart the Skookum IDE” --> I did that --> fixed!

Thanks again for the help! It wasn’t terribly hard to debug things on my end after those clear instructions.

Yep, I did add an additional overlay in the 4.23.1 release. I mentioned it in the release post as well. Updating to a new version can have it’s share of challenges, glad you resolved them.

1 Like