Tutorial 2 - Spawn Cubes

Hey there Mad Scientists!

Yesterday I was trying to do the 2nd tutorial and could not finish it because it was giving me an error.

It won’t accept this part :

4._do  //do the following block of code 4 times
  [       
  BP_Cube2.instances._do  //do the following block of code on all instances of BP_Cube2 objects in our level
    [
    race  //race the _rotate call with the _wait call; essentially rotating for 5 secs
      [
      item._rotate  //item refers to an instance of BP_Cube2
      _wait(5)
      ]    
    ]
  ]
]

I created all the previous members in the level2, created the BP for the cube and the subclass inside skookum.

The item._rotate is not being recognized or something similar…?

Here are some pics to show that, maybe you can figure it out my mistake:

snip_sk

So I just noticed that in my IDE, I also get a red squiggle indicating that _rotate is unknown, when in fact it is not. The 2 questions to ask are:

  1. When you hit the compile button, do you get a green check-mark?
    image
  2. Are there any errors printed in the errors window of the :sk: ide?

If you can answer Yes and No then you are good to go, ignore that red squiggle while we fix things.

  1. I have the green mark checking it did compile

  2. Then yes it did send some error and after i pressed retry/continue it stopped. I did not read the mistake, my bad :confused: !

It did spawn 3 cubes and is rotating the main cube a couple of times ( 4x i guess )

Rotating

So i believe it is working :slight_smile: !

Now I am just waiting for more in-depth game tutorials that work it basics like :

Movement ( Vectors, Rotation, Translation, Local and World ) etc.etc
Camera
Input Management? Like how to use input for in-game actions and events.
A.I?
Other important functionalities which I am not remembering right now :smiley:

Sorry to necro an old thread. I just tried the same demo with the 4.21 version of the :sk: plugin and get exactly the same errors. The code still runs like it’s supposed to, but the red squiggly is still under _rotate and the error message is “The coroutine _rotate() does not exist for an instance of the class Object”. The first time I ran the program, just like the OP, there was a pop-up window asking if I wanted to debug the C++. I selected that option and :ue4: crashed. After reloading :ue4: and running the script again I got the same error message but this time I chose “Ignore” and the program worked. Hope this helps in tracking down the problem.